CCNP ENARSI

CCNP Enterprise: Advanced Routing (Version 8.0) – Conditional Forwarding and Route Redistribution Exam

Chapters 15 - 17: Conditional Forwarding and Route Redistribution Exam

CCNP Enterprise: Advanced Routing ( Version 8.0) – Conditional Forwarding and Route Redistribution Exam

Chapters 15 – 17: Conditional Forwarding and Route Redistribution Exam Answers Full

1. What is the administrative distance of EIGRP-learned routes that have been injected into EIGRP via redistribution?

  • 1
  • 90
  • 100
  • 110
  • 170
  • 180
Explanation: Routes redistributed into EIGRP are external EIGRP routes with an administrative distance of 170.

2. Which statement is true about redistribution behavior?

  • Redistributed routes must exist in the RIB.
  • Redistribution is transitive.
  • Redistribution is not sequential.
  • BGP cannot be redistributed into an IGP.
Explanation: For a route to be redistributed it must exist in the RIB. Redistribution is sequential but not transitive. Although BGP can be redistributed into an IGP, it is not always recommended.

3. Which characteristic describes an OSPF type 1 external route?

  • It is preferred over type 2 external routes.
  • It has a metric that does not change throughout the OSPF domain.
  • It has a default seed metric of 1 for all routes except routes redistributed from BGP.
  • It is the default external route type used by OSPF.
Explanation: There are two types of OSPF external routes, type 1 and type 2. Type 2 is the default setting if not otherwise specified in the redistribute command. The metric for type 1 routes equals the redistribution metric plus the total path metric. For type 2 routes the metric stays the same as the redistribution metric throughout the OSPF domain. The seed metric for BGP-sourced routes redistributed into OSPF is 1.

4. What is the administrative distance for routes redistributed into OSPF?

  • 20
  • 110
  • 170
  • infinity
Explanation: The administrative distance for all OSPF routes is 110.

5. A network engineer has issued the following configuration commands:

router ospf 1
router-id 200.200.200.200
distance ospf intra-area 101 inter-area 104 external 122
network 10.44.11.0 0.0.0.255 area 0
redistribute eigrp 100 metric-type 1

What outcome is expected from the commands issued?

  • The redistributed routes will be tagged by the numeric router-id of 200.200.200.200.
  • Any OSPF routes to the same destination network will be preferred over the redistributed EIGRP routes because of the modification of OSPF AD values.
  • As EIGRP routes are redistributed, the configured metric-type will cause the seed metric to be preserved at the point of redistribution.
  • The classless EIGRP networks will be left out of the redistribution process and only the classful networks will be redistributed.
Explanation: The subnets keyword is extremely important in the redistribution of routes into the OSPF routing process. Without the subnets keyword, only classful networks will be included in the redistribution process.

6. A boundary router is performing mutual redistribution between OSPF and EIGRP. What process should be taken to have an external EIGRP route preferred over an OSPF route to the same destination network?

  • Modify the administrative distance parameter for the external EIGRP routes to be set to 100.
  • Modify the default seed metric to 21 for the source information from OSPF.
  • Modify the administrative distance parameter for the internal EIGRP routes to be set to 180.
  • Modify the default seed metric to 19 for the source information from OSPF.
Explanation: In order to have an external EIGRP route with a default AD of 170 preferred over an OSPF route with a default AD of 110 to the same destination network, the administrative distance value should be modified to a lower value.

7. An IPv6 network topology using redistribution is experiencing reachability issues after migrating from an IPv4 deployment. How is the deployment of IPv6 redistribution different from what it is with IPv4?

  • The local interfaces participating in the source routing protocol are not redistributed unless the include-connected command is issued.
  • The metric keyword is not required in redistributing OSPFv3 into EIGRPv6.
  • The classless networks of a source routing protocol will only be redistributed with the use of the match keyword.
  • The deployment of an IPv6 redistribution process does not support the implementation of route maps.
Explanation: In order to include the networks associated with the local interfaces participating in the routing process that is being redistributed, the include-connected keyword must be used.

8. If multiple seed metrics are defined with redistribution, which metric would be preferred over others?

  • a metric defined in the routing protocol message from the source protocol
  • a metric defined in a route map that was applied to the redistribute command
  • a metric defined in the redistribute command
  • a metric defined using the default-metric command
Explanation: When working with dissimilar routing protocols, a network technician must remember that a seed metric has the following order of preference:

  • A metric defined in the route map that was applied to the redistribute command
  • A metric parameter defined with the redistribute command
  • A metric defined with the default-metric command

9. Which two statements describe default behaviors of route redistribution? (Choose two.)

  • Routes redistributed into OSPF from BGP have a seed metric of 1.
  • Routes redistributed into OSPF have an AD of 20.
  • Routes redistributed into EIGRP have an AD of 190.
  • The BGP weight for redistributed routes is 4096.
  • BGP only redistributes EBGP routes into IGP protocols.
Explanation: Default redistribution behavior is as follows:

  • BGP only redistributes EBGP routes into IGP protocols.
  • Routes redistributed into OSPF from BGP have a seed metric of 1.
  • Routes redistributed into EIGRP have an AD of 170.
  • Routes redistributed into OSPF have an AD of 110.
  • The default BGP weight for redistributed routes is 32,768.

10. What is the default OSPF seed metric for routes redistributed from BGP?

  • 1
  • 10
  • 20
  • infinity
Explanation: Routes learned through another routing protocol are treated as external routes by OSPF. Routes learned from BGP are given a default seed metric of 1. Routes learned from another IGP are given a default seed metric of 20.

11. A network engineer has issued the show run | section router eigrp command. What outcome is expected from the command output?

R1# show run | section router eigrp
router eigrp 99
network 172.21.33.1 0.0.0.0
redistribute ospf 1
ipv6 router eigrp 99
redistribute ospf 1 metric 100000 100 255 1 1500 include-connected
  • The EIGRP for IPv4 configuration will not redistribute OSPF routes without a match keyword.
  • The EIGRP for IPv6 configuration will not redistribute OSPF routes without a match keyword.
  • The EIGRP for IPv4 configuration will not redistribute OSPF routes without the include-connected keyword.
  • The EIGRP for IPv4 configuration will not redistribute OSPF routes without the metric keyword.
Explanation: The metric keyword is required when redistributing OSPF routes into an EIGRP routing process.

12. Refer to the exhibit. Based on the information that is presented, which statement is true?

  • Packets that match access list 1 will be sent to the next-hop address 172.17.1.2.
  • Both match statements must be true for the ISP1 route map to be true.
  • Access list 1 specifies that packets with a destination address of 192.168.1.0 will be policy routed.
  • Access list 2 specifies that packets with a source address of 172.16.1.0 will be policy routed.
  • Packets that match access list 2 will be denied access.
Explanation: Packets that match access-list 2 will have route-map 20 applied. This route map specifies that matching packets will have a policy applied that sends these packets to the next hop 172.17.1.2.

13. Which prefix would match the prefix list ip prefix-list NAME seq 5 permit 10.0.0.0/8 ge 22 le 26 ?

  • 10.0.0.0/8
  • 10.0.0.0/30
  • 10.0.0.0/24
  • 10.0.0.0/16
Explanation: To match the criteria in the prefix list, a prefix must have the same 8 high-order bits as 10.0.0.0/8 and also have a network mask that is equal to or greater than /22 but also less than or equal to /26. The prefix that meets both requirements is 10.0.0.0/24.

14. What are two operational characteristics of policy based routing? (Choose two.)

  • Next-hop addresses defined in PBR set statements are placed in the routing table.
  • PBR examines packets as they exit a router interface.
  • PBR performs conditional forwarding based only on source or destination IP address.
  • Local PBR policies can identify packets that originate from a router.
  • PBR can be configured to forward packets to next-hop addresses that are not in the routing table.
Explanation: PBR has the following characteristics and capabilities:
It examines packets as they enter a router interface.
Local PBR can identify packets that originate from a router.
It can perform conditional forwarding based on packet characteristics in addition to a source or destination IP address.
It can forward packets to next-hop addresses that are not in the routing table by using the set ip default next-hop command.
The next-hop addresses defined in set statements are not placed in the RIB.

15. Refer to the exhibit. Where would the system administrator apply the following configuration to establish policy-based routing that directs packets from the 10.0.0.0/8 network through the R2 router to the Internet?

access-list 111 permit ip 10.0.0.0 0.255.255.255 any

route-map net-10 permit 10
match ip address 111
set interface gigabitethernet 0/1
  • RTA interface G0/0
  • RTB interface G1/0
  • R2 interface G0/0
  • RTA interface G0/1
  • R2 interface G0/1
  • RTB interface G0/1
Explanation: Route maps are applied to inbound interfaces. Therefore, in this example the route map should be placed on the G1/0 interface of router RTB so that it can forward packets destined for the internet through router R2.

16. Which rule applies to route map statements?

  • Sequence numbers increment by 5 automatically if not provided.
  • After a matching criterion, processing continues until all match criteria are checked.
  • Boolean logic “and” is used if multiple variables are configured for a specific route map sequence.
  • A default value of permit is used if there is no processing action defined.
Explanation: Route maps statements have rules as to how they are applied.
If no processing action is provided, the default value is permit .
If no sequence number is provided, the number increments by 10 automatically.
If there is no matching statement, an implied all prefixes statement is applied.
Processing of route map statements stops after a match criterion is matched.

17. What is the default auto-increment sequence number value of a route map if none is specified?

  • 1
  • 5
  • 10
  • 50
Explanation: If a sequence number is not provided in the route map command, the sequence number is auto-incremented by 10.

18. Refer to the exhibit. Two-way redistribution was configured between OSPF and EIGRP on R2. After the redistribution, R3 does not see any external routes coming from the EIGRP domain. The debug ip ospf database external output reveals that no external LSAs are generated for the routes. What could be the problem?

  • A default-metric command is missing from the EIGRP configuration.
  • A distribute list is needed for both OSPF and EIGRP.
  • An area 0 stub command is missing from the OSPF configuration.
  • A subnet keyword is missing from the OSPF configuration.
Explanation: When redistributing into OSPF, if the optional subnets keyword is not included, only classful networks are redistributed.

19. Refer to the exhibit. How will seed metrics be applied to routes redistributed into EIGRP?

  • A seed metric of 0 is set for redistributed RIP routes into EIGRP.
  • RIP routes are redistributed into EIGRP with a seed metric of infinity.
  • Both RIP and OSPF will be redistributed into EIGRP with the same seed metric.
  • OSPF is redistributed into EIGRP with a seed metric of 1.
Explanation: The default seed metric for routes redistributed into EIGRP is infinity. However, since a seed metric is defined by the default-metric command, this new metric is applied to both RIP and OSPF routes when redistributed into EIGRP.

20. Based on the configuration shown, what code will appear in the routing table for redistributed routes on the router?

router ospf 1
router-id 1.1.1.1
network 10.23.1.0 0.0.0.255 area 0
redistribute eigrp 100 subnets metric-type 1
  • O E2
  • O IA
  • O E1
  • D EX
Explanation: The redistribution configuration exists under the destination protocol and identifies the source protocol. The source protocol, EIGRP in this case, provides the network prefixes that are to be redistributed into OSPF. The option for the metric-type keyword is either 1 or 2. Type 2 is the default if not specified. Redistributed routes appear in the routing table with a code of O E1 or OE 2.

21. What default weight metric is used by BGP for routes redistributed from an IGP?

  • 32768
  • 16384
  • 8192
  • 4096
Explanation: BGP assigns a default weight metric of 32,768 to routes redistributed from IGPs.

22. Which two statements describe default redistribution behavior? (Choose two.)

  • Redistributed routes must exist in the RIB.
  • BGP only redistributes IBGP routes into an IGP protocol.
  • Redistribution is transitive between protocols when configured on a single router.
  • Sequential protocol redistribution occurs between multiple routing protocols over a series of routers.
  • The seed metric for redistributed routes is the same for all IGP protocols.
Explanation: For a route to be redistributed, it must exist in the RIB. Redistribution is sequential but not transitive. By default, BGP redistributes only EBGP routes into IGP protocols. Although EBGP can be redistributed into an IGP, it is not always recommended.

23. Refer to the exhibit. Which three network redistribution actions will take place on router R1? (Choose three.)

  • The OSPF route 192.168.1.0 is redistributed into BGP.
  • The OSPF route 192.168.1.0/24 is redistributed into EIGRP.
  • The EIGRP route 172.16.1.0/24 is redistributed into OSPF.
  • The EIGRP route 172.16.1.0/24 is redistributed into BGP.
  • The BGP route 10.0.0.0/8 is redistributed into OSPF.
  • The BGP route 10.0.0.0/8 is redistributed into EIGRP.
Explanation: In redistribution between two protocols, the redistribution configuration is issued under the destination protocol and identifies the source protocol. In redistribution between two or more routing protocols on a single router, redistribution is not transitive.

24. Refer to the exhibit. What metric will RIP routes have when redistributed into EIGRP?

  • K values of 1000 100 255 1 1500
  • infinity
  • zero
  • 100
Explanation: The default seed metric for EIGRP is infinity. In this example a new seed metric for OSPF routes is defined but not for RIP routes. Therefore, RIP routes will have a metric of infinity when redistributed into EIGRP.

25. Which two are characteristics of routes redistributed into EIGRP? (Choose two.)

  • The administrative distance is 200.
  • The administrative distance is 170.
  • The default seed metric is infinity.
  • The default seed metric is 1.
  • The default seed metric is 20.
  • The administrative distance is 90.
Explanation: External EIGRP routes are assigned an administrative distance of 170 and a default seed metric of infinity when they are redistributed into EIGRP.

26. Which characteristic describes an OSPF type 2 external route?

  • It is preferred over type 1 external routes.
  • It is the default external route type used by OSPF.
  • It has a default seed metric of 20 for routes redistributed from BGP.
  • It has a metric that equals the redistribution metric plus the total path metric.
Explanation: There are two types of OSPF external routes, type 1 and type 2. Type 2 is the default setting if not otherwise specified in the redistribute command. The metric for type 1 routes equals the redistribution metric plus the total path metric. For type 2 routes the metric stays the same as the redistribution metric throughout the OSPF domain. The seed metric for BGP-sourced routes redistributed into OSPF is 1.

27. Refer to the exhibit. What redistribution will result from the configuration on R1?

  • Network 172.16.0.0/16 is redistributed into OSPF as a type 1 route with a seed metric of 1.
  • Network 10.23.1.0/24 is redistributed into EIGRP as an external route with a seed metric of infinity.
  • Network 172.16.0.0/16 is redistributed into OSPF as a type 2 route with a seed metric of 20.
  • Network 10.23.1.0/24 is redistributed into EIGRP as an external route with a seed metric of 100.
Explanation: The redistribution configuration exists under the destination protocol and identifies the source protocol. The source protocol, EIGRP in this case, provides the network prefixes that are to be redistributed. Routes redistributed into OSPF from another IGP receive a default seed metric of 20 and a default route type of type 2.

28. What two pieces of information are lost when redistributing routes from one routing source into another routing source and injecting a seed metric at the point of redistribution? (Choose two.)

  • classless networks
  • routing source information
  • classful networks
  • network visibility
  • route tags
Explanation: When routes are being redistributed from one routing source into another routing source, the information from the original routing source is lost when the seed metric is injected at the redistribution point.

29. After the implementation of redistribution on a boundary router, a resource connected to a network consisting of varying link speeds is having a delayed response to user connectivity. What issue might exist?

  • Classless route entries may exist.
  • Routing loops may exist.
  • Incomplete routing tables may exist.
  • Suboptimal routing may exist.
  • Classful route entries may exist.
Explanation: When implementing mutual redistribution on a network with links using a variety of speeds, it is common for suboptimal routing to occur.

30. Refer to the exhibit. A network engineer has issued the verification command while troubleshooting a routing loop on the network. What is the error in the configuration?

  • The route-map is dropping all other routes that do not match the prefix list TAG_10.44.100.0.
  • The match ip address command refers to the incorrect prefix list.
  • The redistribute command is configured to filter routes using the route map instead of the prefix list.
  • The route-map sequence 20 is missing the match and set statements.
Explanation: Router BR1 is configured to set a tag of 10 for the routes identified by the prefix list of 10.44.100.0. However, the prefix list being referenced is incorrect and does not exist.

31. While configuring a boundary router that utilizes OSPF and BGP, a network engineer performs redistribution without modifying source or destination metrics. What default value is the engineer using for successful redistribution?

  • default administrative distance
  • default classful redistribution
  • default seed metric
  • default classless redistribution
Explanation: The default seed metric is used by specific routing protocols to provide a default metric value for a destination routing process. This ensures that a metric is available and a route can become reachable after the redistribution process between varying routing protocols.

32. Refer to the exhibit. A network engineer has issued the commands shown on a boundary router. What is the result of this command?

  • The EIGRP AS 90 process has been configured to redistribute RIP routes.
  • The internal administrative distance for EIGRP AS 90 has been changed to 120.
  • The external administrative distance for EIGRP AS 90 has been changed to 120.
  • The default seed metric for EIGRP AS 90 has been changed to 120.
Explanation: The EIGRP configuration command distance eigrp ad-internal ad-external is used to modify the default administrative distance on IOS routers. The valid values for the AD are between 1 and 255; a value of 255 stops the installation of the route into the routing information base (RIB).

33. Refer to the exhibit. A junior administrator issues the show ip protocol command while troubleshooting missing NSSA OSPF routes. What is the most likely cause for the missing OSPF routes?

  • The BGP configuration is not using automatic summarization.
  • The BGP configuration is configured for IBGP instead of EBGP.
  • The redistribute command is not issued with a match keyword.
  • The redistribute command is not issued with a metric keyword.
Explanation: The redistribution process does not include external OSPF routes by default. In order to allow the external OSPF routes to be implemented with redistribution, the match keyword should be used.

34. A network engineer has issued the following configuration commands:

router ospf 10
router-id 10.10.10.10
distance ospf intra-area 105 inter-area 107 external 144
network 10.44.11.0 0.0.0.255 area 0

router bgp 65001
address-family ipv6 unicast
redistribute ospf 10

What outcome is expected from the commands issued?

  • The internal routes in the OSPF process are redistributed into the BGP protocol and the external OSPF routes are not included.
  • The BGP protocol is unable to process the redistributed OSPF routes unless a metric is defined.
  • The configuration is missing a route map in order to match the OSPF routes that require redistribution.
  • The local interfaces participating in the OSPF process are redistributed into the BGP protocol.
Explanation: When OSPF is being redistributed into BGP, the match keyword must be included during redistribution in order to include external OSPF routes. Without the match keyword, only internal OSPF routes are included in the redistribution process.

35. Which three statements describe ACL processing of packets? (Choose three.)

  • Each packet is compared to the conditions of every statement in the ACL before a forwarding decision is made.
  • A packet can either be rejected or forwarded as directed by the statement that is matched.
  • A packet that does not match the conditions of any ACL statements will be forwarded by default.
  • An implicit deny any rejects any packet that does not match any ACL statement.
  • A packet that has been denied by one statement can be permitted by a subsequent statement.
  • Each statement is checked only until a match is detected or until the end of the ACL statement list is reached.
Explanation: ACLs are processed in a top down manner. When an ACL is inspected, if the information in a packet header and an ACL statement match, the remaining statements are not examined, and the packet is either denied or permitted through as specified by the ACL. If a packet header does not match an ACL statement, the packet is tested against the next statement in the list. This matching process continues until the end of the list is reached. Every ACL has an implied deny at the end of the list. This implied deny statement is applied to all packets for which conditions did not test true.

36. Which two network prefixes match the prefix match pattern 10.168.0.0/13 ge 24? (Choose two.)

  • 10.104.0.0/24
  • 10.168.0.0/24
  • 10.173.1.0/28
  • 10.168.1.0/22
  • 10.168.0.0/13
Explanation: To match the criterion of the need for a prefix match pattern, a prefix must have the same 13 high-order bits as 10.168.0.0/13 and also have a network mask that is equal to or greater than /24. The two prefixes that meet both requirements are 10.168.0.0/24 and 10.173.1.0/28.

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button