120 Labs for Cisco CCNA 200-125 and CCENT Exams

Challenge Lab 10: DHCP, Inter-VLAN Routing, and RIPv2

Lab Objective:

This is a challenge lab designed to test and validate the skills you have acquired throughout this lab guide on DHCP, inter-VLAN routing, and RIP version 2.

Lab Purpose:

The purpose of this lab is to reinforce DHCP, inter-VLAN routing, and RIP version 2 configuration.

Certification Level:

This lab is suitable for CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 8/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 20 minutes.

Lab Topology:

Please use the following topology to complete this lab:

Task 1:

Configure the hostname on all devices as illustrated in the network topology.

Task 2:

Configure Sw1 as a VTP server and Sw2 as a VTP client. Both switches should be in VTP domain CISCO. Configure the F0/1 interfaces on both switches as trunk links. Verify that your trunk link is operational and propagating all VLAN information.

Task 3:

Configure the following VLANs on Sw1:

Task 4:

Make sure your VLAN information propagates to Sw2. Next, configure Sw1 Fa0/2 as a trunk link and Fa0/3 in VLAN20. Configure Sw2 Fa0/2 in VLAN30 and Fa0/3 in VLAN40.

Task 5:

Configure IP addresses as specified in the topology on R2 and R4. On Sw1 and Sw2, configure interface VLAN10 with an IP address of 10.1.1.2/24 and 10.1.1.3/24, respectively. The default gateway of all switches should be 10.1.1.1.

Task 6:

Configure subinterfaces on R1 as illustrated in the topology. Ensure that Fa0/0.10 is in VLAN10, Fa0/0.20 is in VLAN20, Fa0/0.30 is in VLAN30, and Fa0/0.40 is in VLAN40.

Task 7:

Configure R1 as a Cisco IOS DHCP server for the 10.3.3.0/27 subnet. The domain name should be howtonetwork.com; the default gateway should be 10.3.3.1; the DHCP lease should be for 7 days. Next, configure R3 to receive IP addressing on F0/0 via DHCP. Some of these commands won’t work on Packet Tracer.

Task 8:

Configure RIP version 2 on R1, R2, R3, and R4. Make sure that there is no automatic summarization.

Task 9:

If you have configured everything correctly, all routers and all switches should be able to ping each other. Verify this to see if you have completed the lab successfully.

Solution

Show Runs

R1#show run 
! 
hostname R1 
! 
ip dhcp pool funpool 
network 10.3.3.0 255.255.255.224 
default-router 10.3.3.1 
domain-name howtonetwork.com 
default-router 10.3.3.1 
lease 7 
! 
interface FastEthernet0/0 
no ip address 
duplex auto 
speed auto 
! 
interface FastEthernet0/0.10 
encapsulation dot1Q 10 
ip address 10.1.1.1 255.255.255.0 
! 
interface FastEthernet0/0.20 
encapsulation dot1Q 20 
ip address 10.2.2.1 255.255.255.252 
! 
interface FastEthernet0/0.30 
encapsulation dot1Q 30 
ip address 10.3.3.1 255.255.255.224 
! 
interface FastEthernet0/0.40 
encapsulation dot1Q 40
ip address 10.4.4.1 255.255.255.248 
! 
interface Vlan1 
no ip address 
shutdown 
! 
router rip 
version 2 
network 10.0.0.0 
no auto-summary 

R2#show run 
Building configuration... 
! 
hostname R2 
! 
interface FastEthernet0/0 
ip address 10.2.2.2 255.255.255.252 
duplex auto 
speed auto 
! 
router rip 
version 2 
network 10.0.0.0 
no auto-summary 
! 

R3#show run 
Building configuration... 
! 
hostname R3 
! 
interface FastEthernet0/0 
ip address dhcp 
duplex auto
speed auto 
! 
router rip 
version 2 
network 10.0.0.0 
no auto-summary 
! 

R4#show run 
Building configuration... 
! 
hostname R4 
! 
interface FastEthernet0/0 
ip address 10.4.4.4 255.255.255.248 
duplex auto 
speed auto 
! 
router rip 
version 2 
network 10.0.0.0 
no auto-summary 

Sw1#show run 
Building configuration... 
! 
hostname Sw1
! 
spanning-tree mode pvst 
! 
interface FastEthernet0/1 
switchport mode trunk 
! 
interface FastEthernet0/2 
switchport mode trunk
! 
interface FastEthernet0/3 
switchport access vlan20 
switchport mode access 
! 
interface Vlan1 
no ip address 
shutdown 
! 
interface Vlan10 
mac-address 0002.4add.7001 
ip address 10.1.1.2 255.255.255.0 
! 
ip default-gateway 10.1.1.1 

Sw2#show run 
Building configuration... 
! 
hostname Sw2 
! 
interface FastEthernet0/1 
switchport mode trunk 
! 
interface FastEthernet0/2 
switchport access vlan30 
switchport mode access 
! 
interface FastEthernet0/3 
switchport access vlan40 
switchport mode access 
! 
interface Vlan1 
no ip address 
shutdown
! 
interface Vlan10 
mac-address 0001.c700.7c01 
ip address 10.1.1.3 255.255.255.0 
! 
ip default-gateway 10.1.1.1

TEST:

R2#ping 10.2.2.1 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms 

R2#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, 
       B – BGP, D - EIGRP, EX - EIGRP external, O - OSPF, 
       IA - OSPF inter area, N1 - OSPF NSSA external type 1, 
       N2 - OSPF NSSA external type 2, E1 - OSPF external type 1, 
       E2 - OSPF external type 2, E – EGP, i - IS-IS, 
       L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area, 
       * - candidate default, U - per-user static route, 
       o – ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

        10.0.0.0/8 is variably subnetted, 4 subnets, 4 masks 
R       10.1.1.0/24 [120/1] via 10.2.2.1, 00:00:26, FastEthernet0/0 
C       10.2.2.0/30 is directly connected, FastEthernet0/0 
R       10.3.3.0/27 [120/1] via 10.2.2.1, 00:00:26, FastEthernet0/0 
R       10.4.4.0/29 [120/1] via 10.2.2.1, 00:00:26, FastEthernet0/0 

R3#show ip int brief 
Interface        IP-Address  OK? Method Status                Protocol
FastEthernet0/0  10.3.3.2    YES DHCP   up                    up
R3# 

R3#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, 
       ia - IS-IS inter area, * - candidate default, 
       U - per-user static route, o - ODR 
       P - periodic downloaded static route 

Gateway of last resort is 10.3.3.1 to network 0.0.0.0 

        10.0.0.0/8 is variably subnetted, 4 subnets, 4 masks 
R       10.1.1.0/24 [120/1] via 10.3.3.1, 00:00:08, FastEthernet0/0 
R       10.2.2.0/30 [120/1] via 10.3.3.1, 00:00:08, FastEthernet0/0 
C       10.3.3.0/27 is directly connected, FastEthernet0/0 
R       10.4.4.0/29 [120/1] via 10.3.3.1, 00:00:08, FastEthernet0/0 
S*   0.0.0.0/0 [254/0] via 10.3.3.1 

R3#ping 10.2.2.2 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms 

R3# 

Sw2#show vlan brief 
VLAN Name                    Status    Ports 
---- ----------------------- --------- ------------------------------- 
1    default                 active    Fa0/4, Fa0/5, Fa0/6, Fa0/7 
                                       Fa0/8, Fa0/9, Fa0/10, Fa0/11 
                                       Fa0/12, Fa0/13, Fa0/14, Fa0/15 
                                       Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                       Fa0/20, Fa0/21, Fa0/22, Fa0/23 
                                       Fa0/24, Gig0/1, Gig0/2 
10   VLAN-10                 active     
20   VLAN-20                 active     
30   VLAN-30                 active    Fa0/2 
40   VLAN-40                 active    Fa0/3 
1002 fddi-default            active     
1003 token-ring-default      active     
1004 fddinet-default         active     
1005 trnet-default           active     

Sw2#show vtp status
 VTP Version                     : 2 
Configuration Revision          : 8 
Maximum VLANs supported locally : 255 
Number of existing VLANs        : 9 
VTP Operating Mode              : Client 
VTP Domain Name                 : CISCO 
VTP Pruning Mode                : Disabled 
VTP V2 Mode                     : Disabled 
VTP Traps Generation            : Disabled 
MD5 digest                      : 0xBA 0x39 0x13 0x74 0x56 0x60 0xCF 0xF9
 Configuration last modified by 0.0.0.0 at 3-1-93 00:04:45 
Sw2# 

Sw1#show int trunk 
Port        Mode         Encapsulation  Status        Native vlan 
Fa0/1       on           802.1q         trunking      1 
Fa0/2       on           802.1q         trunking      1 

Port        Vlans allowed on trunk 
Fa0/1       1-1005 
Fa0/2       1-1005 

Port        Vlans allowed and active in management domain 
Fa0/1       1,10,20,30,40
Fa0/2       1,10,20,30,40 

Port        Vlans in spanning tree forwarding state and not pruned 
Fa0/1       1,10,20,30,40 
Fa0/2       1,10,20,30,40 

Sw1#

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button