120 Labs for Cisco CCNA 200-125 and CCENT Exams

Challenge Lab 14: Easy EIGRP

Lab Objective:

The objective of this lab exercise is for you to configure EIGRP using two ASNs. One ASN will run between RouterA and RouterB and the other between RouterB and RouterC.

Lab Purpose:

EIGRP is a fundamental CCNA topic. I have provided show runs and test commands where appropriate.

Certification Level:

This lab is suitable for both ICND and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 7/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 15 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure the topology above. Test by pinging from RouterA to RouterB, then RouterB to RouterC. You will not be able to ping from A to C until you have configured EIGRP.

Task 2:

Configure EIGRP between all routers with each interface/subnet and with the correct ASN.

Task 3:

Check your configurations with show commands.

Solution

I cheated a bit here so you may have struggled. ASN 10 will not speak to ASN 20 without you adding another command not covered in the CCNA exam. But, I do know that Cisco can be sneaky and I’ve seen other stuff not in the syllabus put into the exam, leaving the test-taker confused and angry! I can’t say I blame them.

Just have a play with the redistribute command and then re-do the lab, but just put everything into ASN 10 and it will work fine. I just wanted to give you an extra command to learn just in case.

Show Runs 

RouterA 

hostname RouterA 
! 
interface Serial0/0 
ip address 10.0.0.1 255.255.255.252 
clock rate 2000000 
! 
router eigrp 10 
network 10.0.0.0 0.0.0.3 
no auto-summary 

RouterB

hostname RouterB 
! 
interface Serial0/0 
ip address 10.0.0.2 255.255.255.252 
clock rate 2000000
! 
interface Serial0/1 
ip address 172.16.1.1 255.255.255.252 
clock rate 2000000 
! 
router eigrp 10 
redistribute eigrp 20 
network 10.0.0.0 0.0.0.3 
no auto-summary 
! 
router eigrp 20 
redistribute eigrp 10 
network 172.16.1.0 0.0.0.3 
no auto-summary 

RouterC 

hostname RouterC
! 
interface Serial0/0 
ip address 172.16.1.2 255.255.255.252 
clock rate 2000000 
! 
router eigrp 20 
network 172.16.1.0 0.0.0.3 
no auto-summary

TEST:

RouterA#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP, 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area, 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2, 
       E1 - OSPF external type 1, E2 - OSPF external type 2,
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
       L2 - IS-IS level-2, ia - IS-IS inter area, 
       * - candidate default, U - per-user static route, 
       o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

        172.16.0.0/30 is subnetted, 1 subnets 
D EX    172.16.1.0 [170/2681856] via 10.0.0.2, 00:05:33, Serial0/0 
        10.0.0.0/30 is subnetted, 1 subnets 
C       10.0.0.0 is directly connected, Serial0/0 

RouterC#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP, 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area, 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2, 
       E1 - OSPF external type 1, E2 - OSPF external type 2, 
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
       L2 - IS-IS level-2, ia - IS-IS inter area, 
       * - candidate default, U - per-user static route, 
       o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

        172.16.0.0/30 is subnetted, 1 subnets 
C       172.16.1.0 is directly connected, Serial0/0 
        10.0.0.0/30 is subnetted, 1 subnets 
D EX    10.0.0.0 [170/2681856] via 172.16.1.1, 00:06:42, Serial0/0

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button