120 Labs for Cisco CCNA 200-125 and CCENT Exams

Challenge Lab 16: Multi-Area OSPF

Lab Objective:

The objective of this lab exercise is for you to configure OSPF on three routers using more than one area.

Lab Purpose:

Multi-Area OSPF is a core ICND2 topic. I have provided show runs and test commands where appropriate.

Certification Level:

This lab is suitable for both ICND2 and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 7/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 15 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure the topology above. Test by pinging from RouterA to RouterB, then RouterB to RouterC. You will not be able to ping from A to C until you have configured OSPF.

Task 2:

Configure OSPF between all routers with each interface/subnet in the correct area.

Task 3:

Check your configurations with show commands.

Solution

There is a sneaky gotcha in this lab. I hope you spotted it.

The 10.0.0.0 network is not in the first subnet (the zero subnet), so putting the configuration below in for the ospf network won’t work:

network 10.0.0.0 0.0.0.3 Area 0

The reason is that this would advertise hosts .1 and .2, so if you want to advertise the hosts in the 10.0.0.4 network, which are .5 and .6, you need to enter:

network 10.0.0.4 0.0.0.3 Area 0 

Show Runs 

RouterA 

hostname RouterA 
! 
interface Loopback0 
ip address 192.168.1.1 255.255.255.252 
! 
interface Serial0/0 
ip address 10.0.0.5 255.255.255.252 
clock rate 2000000 
!          
router ospf 1 
log-adjacency-changes 
network 10.0.0.4 0.0.0.3 area 0 
network 192.168.1.0 0.0.0.3 area 2 

RouterB 

hostname RouterB
! 
interface Serial0/0 
ip address 10.0.0.6 255.255.255.252 
clock rate 2000000 
! 
interface Serial0/1 
ip address 172.16.1.1 255.255.255.252 
clock rate 2000000 
! 
router ospf 1 
log-adjacency-changes 
network 10.0.0.4 0.0.0.3 area 0 
network 172.16.1.0 0.0.0.3 area 1 

RouterC 

hostname RouterC 
! 
interface Serial0/0 
ip address 172.16.1.2 255.255.255.252 
clock rate 2000000 
! 
router ospf 1 
log-adjacency-changes 
network 172.16.1.0 0.0.0.3 area 1

TEST:

RouterA#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP, 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area, 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2, 
       E1 - OSPF external type 1, E2 - OSPF external type 2,
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
       L2 - IS-IS level-2, ia - IS-IS inter area, 
       * - candidate default, U - per-user static route, 
       o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

        172.16.0.0/30 is subnetted, 1 subnets 
O IA    172.16.1.0 [110/128] via 10.0.0.6, 00:06:32, Serial0/0 
        10.0.0.0/30 is subnetted, 1 subnets 
C       10.0.0.4 is directly connected, Serial0/0 
        192.168.1.0/30 is subnetted, 1 subnets 
C       192.168.1.0 is directly connected, Loopback0 

RouterA#show ip ospf neighbor 

Neighbor ID     Pri   State      Dead Time   Address         Interface 
172.16.1.1        0   FULL/  -   00:00:30    10.0.0.6        Serial0/0 

RouterA#show ip protocols 
Routing Protocol is “ospf 1” 
 Outgoing update filter list for all interfaces is not set 
 Incoming update filter list for all interfaces is not set 
 Router ID 192.168.1.1 
 It is an area border router 
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa 
 Maximum path: 4 
 Routing for Networks: 
  10.0.0.4 0.0.0.3 area 0 
  192.168.1.0 0.0.0.3 area 2 
Reference bandwidth unit is 100 mbps 
 Routing Information Sources: 
  Gateway         Distance      Last Update 
  192.168.1.1          110      00:08:43 
  172.16.1.1           110      00:07:11
 Distance: (default is 110) 

RouterC#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP, 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area, 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2, 
       E1 - OSPF external type 1, E2 - OSPF external type 2, 
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
       L2 - IS-IS level-2, ia - IS-IS inter area, 
       * - candidate default, U - per-user static route, 
       o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

        172.16.0.0/30 is subnetted, 1 subnets 
C       172.16.1.0 is directly connected, Serial0/0 
        10.0.0.0/30 is subnetted, 1 subnets 
O IA    10.0.0.4 [110/128] via 172.16.1.1, 00:00:15, Serial0/0 
        192.168.1.0/32 is subnetted, 1 subnets 
O IA    192.168.1.1 [110/129] via 172.16.1.1, 00:00:15, Serial0/0 

RouterC#ping 192.168.1.1 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: 
!!!!!

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button