120 Labs for Cisco CCNA 200-125 and CCENT Exams

Challenge Lab 17: Multi-Area OSPF with Passive Interfaces

Lab Objective:

The objective of this lab exercise is for you to configure OSPF on three routers using more than one area. You will then use the passive-interface default command to turn off Hellos on all interfaces for RouterA and then enable them on the Serial interface on that router.

Lab Purpose:

Multi-Area OSPF is a core ICND2 topic and you must understand how to use the passive interface command. I have provided show runs and test commands where appropriate.

Certification Level:

This lab is suitable for both ICND2 and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 7/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 15 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure the topology above. Test by pinging from RouterA to RouterB, then RouterB to RouterC. You will not be able to ping from A to C until you have configured OSPF.

Task 2:

Configure OSPF between all routers with each interface/subnet in the correct area.

Task 3:

Make all interfaces on RouterA passive and then enable Serial0/0.

Test 4:

Check your configurations.

Solution

The passive-interface command produces different results for different protocols. The interface for OSPF will no longer send Hellos and so an adjacency will not form on this link. LSAs will be sent however. In this lab, I’ve set all OSPF interfaces to be passive but then enabled the Serial interface.

Show Runs 

RouterA 

hostname RouterA 
! 
interface Loopback0 
ip address 192.168.1.1 255.255.255.252 
! 
interface Serial0/0 
ip address 10.0.0.5 255.255.255.252 
clock rate 2000000 
! 
router ospf 1 
log-adjacency-changes 
passive-interface default 
no passive-interface Serial0/0 
network 10.0.0.4 0.0.0.3 area 0 
network 192.168.1.0 0.0.0.3 area 2 

RouterB 

hostname RouterB 
! 
interface Serial0/0 
ip address 10.0.0.6 255.255.255.252 
clock rate 2000000 
!
interface Serial0/1 
ip address 172.16.1.1 255.255.255.252 
clock rate 2000000 
! router ospf 1 
log-adjacency-changes 
network 10.0.0.4 0.0.0.3 area 0 
network 172.16.1.0 0.0.0.3 area 1 

RouterC 

! 
hostname RouterC 
! 
interface Serial0/0 
ip address 172.16.1.2 255.255.255.252 
clock rate 2000000 
! 
interface FastEthernet0/1 
no ip address 
shutdown 
duplex auto 
speed auto 
! 
router ospf 1 
log-adjacency-changes 
network 172.16.1.0 0.0.0.3 area 1

TEST:

RouterA#show ip prot 
Routing Protocol is “ospf 1” 
 Outgoing update filter list for all interfaces is not set 
 Incoming update filter list for all interfaces is not set 
 Router ID 192.168.1.1 
 It is an area border router
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa 
 Maximum path: 4 
 Routing for Networks: 
  10.0.0.4 0.0.0.3 area 0 
  192.168.1.0 0.0.0.3 area 2 
Reference bandwidth unit is 100 mbps 
 Passive Interface(s): 
  FastEthernet0/0 
  FastEthernet0/1 
  Loopback0     
 Routing Information Sources: 
  Gateway         Distance      Last Update 
  10.0.0.6             110      00:00:04 
  192.168.1.1          110      00:05:54 
 Distance: (default is 110)

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button