120 Labs for Cisco CCNA 200-125 and CCENT Exams

Lab 100: Configuring GRE Point-To-Point Tunnels

Lab Objective

The objective of this lab exercise is for you to learn how to configure point-to-point GRE tunnels.

Lab Purpose:

Generic Routing Encapsulation (GRE) is IP protocol number 47; its main purpose is to encapsulate any network layer protocol. As a Cisco engineer, as well as in the Cisco CCNA exam, you will be expected to know how to implement GRE tunnels.

Certification Level:

This lab is suitable for ICND2 and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 7/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 20 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure hostnames on R1 and R2 as illustrated in the topology (R1 is on the left).

Task 2:

Configure each router with its respective IPv4 addresses on both of their FastEthernet interfaces.

Task 3:

Configure a GRE tunnel (numbered 1) on each router with the respective IPv4 address (10.10.10.0/30) as per the diagram and add the following settings:

  • Tunnel source is interface f0/0;
  • Tunnel destination is the other router’s interface f0/0; and
  • Set the tunnel mode to GRE.

Task 4:

Configure a static route on R1 to 192.168.2.0/24 via the Tunnel 1 interface, and configure a static route on R2 to 192.168.1.0/24 via the Tunnel 1 interface.

Task5:

Check the status of the interface tunnel and make sure that traffic is flowing through the tunnel as expected.

Configuration and Verification

Task 1:

For reference information on configuring hostnames, please refer to earlier labs.

Task 2:

For reference information on configuring IP addressing, please refer to earlier labs.

Task 3:

R1#config t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#int Tunnel 1 
R1(config-if)#ip address 10.10.10.1 255.255.255.252 
R1(config-if)#tunnel source f0/0 
R1(config-if)#tunnel destination 172.16.1.2 
R1(config-if)#tunnel mode gre ip 

R2(config)#int Tunnel 1 
R2(config-if)#ip address 10.10.10.2 255.255.255.252 
R2(config-if)#tunnel source f0/0 
R2(config-if)#tunnel destination 172.16.1.1 
R2(config-if)#tunnel mode gre ip

Task 4:

R1(config)#ip route 192.168.2.0 255.255.255.0 tunnel 1 

R2(config)#ip route 192.168.1.0 255.255.255.0 tunnel 1

Task 5:

R1#sh ip interface brief 
Interface        IP-Address      OK? Method Status       Protocol 
FastEthernet0/0  172.16.1.1      YES manual up           up
FastEthernet0/1  192.168.1.1     YES manual up           up       
Tunnel1          10.10.10.1      YES manual up           up       

R2#sh ip int brief 
Interface          IP-Address      OK? Method Status     Protocol 
FastEthernet0/0    172.16.1.2      YES manual up         up       
FastEthernet0/1    192.168.2.1     YES manual up         up       
Tunnel1            10.10.10.2      YES manual up         up 

R1#show interface tunnel 1 
Tunnel1 is up, line protocol is up 
 Hardware is Tunnel 
 Internet address is 10.10.10.1/30 
 MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec, reliability 255/255, txload 1/255, rxload 1/255 
 Encapsulation TUNNEL, loopback not set 
 Keepalive not set 
 Tunnel source 172.16.1.1 (FastEthernet0/0), destination 172.16.1.2 
 Tunnel protocol/transport GRE/IP 

R2#show interface tunnel 1 
Tunnel1 is up, line protocol is up 
 Hardware is Tunnel 
 Internet address is 10.10.10.2/30 
 MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec, reliability 255/255, txload 1/255, rxload 1/255 
 Encapsulation TUNNEL, loopback not set 
 Keepalive not set 
 Tunnel source 172.16.1.2 (FastEthernet0/0), destination 172.16.1.1 
 Tunnel protocol/transport GRE/IP

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button