120 Labs for Cisco CCNA 200-125 and CCENT Exams

Lab 27: Configuring RIP version 2

Lab Objective:

The objective of this lab exercise is for you to learn and understand how to configure Routing Information Protocol version 2 on a Cisco IOS router.

Lab Purpose:

RIPv2 configuration is a fundamental skill. By default, when RIP is enabled on a Cisco router, both version 1 and version 2 updates are sent and received. Since RIPv1 is considered obsolete because of today’s subnetted networks, it is imperative that you know how to enable RIPv2. As a Cisco engineer, as well as in the Cisco CCNA exam, you will be expected to know how to configure and verify RIPv2.

Certification Level:

This lab is suitable for both CCENT and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 5/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 10 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure the hostnames on routers R1 and R2 as illustrated in the topology.

Task 2:

Configure a back-to-back Serial connection between R1 and R2. Configure the DCE interface Serial0/0 in R2 to provide clocking to R1 at a clock speed of 2 Mbps (if this is the DCE end). Configure IP addresses 192.168.0.1/30 and 192.168.0.2/30 on R1 and R2 Serial0/0 interfaces, respectively. Configure the Loopback interfaces on R1 with the IP addresses illustrated in the topology.

Task 3:

Enable RIPv2 on R1 and configure RIPv2 routing for the Loopback interfaces and the Serial0/0 interface. Verify on either R1 or R2 that RIPv2 has been enabled using the appropriate commands.

Configuration and Verification

Task 1:

For reference information on configuring hostnames, please refer to earlier labs.

Task 2:

R2#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R2(config)#int s0/0 
R2(config-if)#clock rate 2000000 
R2(config-if)#end 
R2# 
R2#sh controllers s0/0 
Interface Serial0/0 
Hardware is PowerQUICC MPC860 
DCE V.35, clock rate 2000000 

R1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#int s0/0 
R1(config-if)#ip add 192.168.0.1 255.255.255.252 
R1(config-if)#no shutdown 
R1(config)#int loop100 
R1(config-if)#ip add 10.10.100.1 255.255.255.224 
R1(config-if)#exit 
R1(config)#int loop101 
R1(config-if)#ip add 10.10.101.1 255.255.255.192 
R1(config-if)#end 
R1# 

R2#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R2(config)#int s0/0
R2(config-if)#ip address 192.168.0.2 255.255.255.252 
R1(config-if)#no shutdown 
R2(config-if)#end 
R2# 

R1#ping 192.168.0.2 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms 

R2#ping 192.168.0.1 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Task 3:

R1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#router rip 
R1(config-router)#version 2 
R1(config-router)#network 10.0.0.0 
R1(config-router)#network 192.168.0.0 
R1(config-router)#end 
R1# 

R2#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R2(config)#router rip 
R2(config-router)#version 2 
R2(config-router)#network 192.168.0.0 
R2(config-router)#end 
R2#

NOTE: When configuring RIP routing, you must use the version 2 keyword under RIP configuration mode. By default, if RIP is enabled and this keyword is not issued, the Cisco IOS router will enable both RIPv1 and RIPv2. RIPv1 will be enabled for inbound and outbound routing updates, and RIPv2 will be enabled only for inbound routing updates. This is illustrated below for a router configured for RIP routing without the version 2 keyword:

R1#show ip protocols 
Routing Protocol is “rip” 
 Sending updates every 30 seconds, next due in 9 seconds 
 Invalid after 180 seconds, hold down 180, flushed after 240 
 Outgoing update filter list for all interfaces is not set 
 Incoming update filter list for all interfaces is not set 
 Redistributing: rip 
 Default version control: send version 1, receive any version     
 Interface             Send  Recv  Triggered RIP  Key-chain     
 Serial0/0             1     1 2

The next thing to remember when enabling RIP is to always specify the network at its major classful boundary, regardless of the fact that it has been subnetted. For example, R1 has two Loopback interfaces: 10.10.100.1/27 and 10.10.101.1/26. Because these are part of the 10.0.0.0/8 subnet (which is a Class A address) the RIP network statement is configured using their major classful boundary and is configured as network 10.0.0.0 in RIP configuration mode.

R1#show ip protocols 
Routing Protocol is “rip” 
 Sending updates every 30 seconds, next due in 12 seconds 
 Invalid after 180 seconds, hold down 180, flushed after 240 
 Outgoing update filter list for all interfaces is not set 
 Incoming update filter list for all interfaces is not set 
 Redistributing: rip 
 Default version control: send version 2, receive version 2 
  Interface             Send  Recv  Triggered RIP  Key-chain 
  Serial0/0             2     2
  Loopback100           2     2 
  Loopback101           2     2 
 Automatic network summarization is in effect 
 Maximum path: 4 
 Routing for Networks: 
  10.0.0.0 
  192.168.0.0 
 Routing Information Sources: 
  Gateway         Distance      Last Update 
  192.168.0.2          120      00:02:47 
 Distance: (default is 120)

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button