120 Labs for Cisco CCNA 200-125 and CCENT Exams

Lab 72: Configure, Verify, and Troubleshoot EtherChannels (Static/PAgP/LACP)

Lab Objective:

The objective of this lab exercise is for you to learn and understand how to use redundant links between Cisco switches in order to build port channels.

Lab Purpose:

Understanding how to enable the different port-channel protocols on a Layer 2 network is a must for every engineer to know. As a Cisco engineer, as well as in the Cisco CCNA exam, you will be expected to know how to configure port-channels using LACP, PAgP or the ON mechanism.

Certification Level:

This lab is suitable for ICND2 and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 7/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 20 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure the hostnames on Sw1, Sw2, and Sw3 as illustrated in the topology.

Task 2:

Create two VLANs on every switch as follows:

  • VLAN10: Data
  • VLAN20: Management

Task 3:

Configure each switchport shown in the diagram as a trunk and make sure all VLANs are allowed.

Task 4:

Start configuring the port channels as follows:

  • Links between Sw1 and Sw2: Port channel 1/Protocol LACP
  • Links between Sw1 and Sw3: Port channel 2/Protocol PAgP
  • Links between Sw2 and Sw3: Port channel 3/Use the ON mode

Note: You can select which side is active/passive or desirable/auto.

Task 5:

Make sure each port channel is up and running by issuing the following command on each switch:

show etherchannel summary

Configuration and Verification

Task 1:

For reference information on configuring hostnames, please refer to earlier labs.

Task 2:

For reference information on configuring VLANs, please refer to earlier labs.

Task 3:

SW1(config)#int range fa0/1-4 
SW1(config-if-range)#switchport mode trunk 
SW1(config-if-range)#switchport trunk allow vlan all 
SW1(config-if-range)#exit 
SW1(config)# 

SW2(config)#int range fa0/1-4 
SW2(config-if-range)#switchport mode trunk 
SW2(config-if-range)#switchport trunk allow vlan all 
SW2(config-if-range)#exit 
SW2(config)# 

SW3(config)#int range fa0/1-4 
SW3(config-if-range)#switchport mode trunk 
SW3(config-if-range)#switchport trunk allow vlan all 
SW3(config-if-range)#exit 
SW3(config)#

Task 4:

SW1(config)#interface range fa0/1-2 
SW1(config-if-range)#channel-group 1 mode active
SW1(config-if-range)#exit 
SW1(config)# 

SW1(config)#interface range fa0/3-4 
SW1(config-if-range)#channel-group 2 mode desirable 
SW1(config-if-range)#exit 
SW1(config)# 

SW2(config)#interface range fa0/1-2 
SW2(config-if-range)#channel-group 1 mode passive 
SW2(config-if-range)#exit 
SW2(config)# 

SW2(config)#interface range fa0/3-4 
SW2(config-if-range)#channel-group 3 mode on 
SW2(config-if-range)#exit 
SW2(config)# 

SW3(config)#interface range fa0/1-2 
SW3(config-if-range)#channel-group 2 mode auto 
SW3(config-if-range)#exit 
SW3(config)# 

SW3(config)#interface range fa0/3-4 
SW3(config-if-range)#channel-group 3 mode on 
SW3(config-if-range)#exit 
SW3(config)#

Task 5:

SW1#show etherchannel summary 
Flags:  D - down        P - in port-channel 
        I - stand-alone s - suspended 
        H - Hot-standby (LACP only) 
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator 
        u - unsuitable for bundling 
        w - waiting to be aggregated 
        d - default port 

Number of channel-groups in use: 2 
Number of aggregators: 2 

Group  Port-channel  Protocol    Ports 
------+-------------+-----------+------------------------------------ 

1      Po1(SU)           LACP   Fa0/1(P) Fa0/2(P) 
2      Po2(SU)           PAgP   Fa0/3(P) Fa0/4(P) 

SW2#show etherchannel summary 
Flags:  D - down        P - in port-channel 
        I - stand-alone s - suspended 
        H - Hot-standby (LACP only) 
        R - Layer3      S - Layer2 
        U - in use      f - failed to allocate aggregator 
        u - unsuitable for bundling 
        w - waiting to be aggregated 
        d - default port 

Number of channel-groups in use: 2 
Number of aggregators: 2 

Group  Port-channel  Protocol    Ports 
------+-------------+-----------+------------------------------------ 

1      Po1(SU)           LACP   Fa0/1(P) Fa0/2(P) 
3      Po3(SU)           -      Fa0/3(D) Fa0/4(P) 

SW3#show etherchannel summary 
Flags:  D - down        P - in port-channel 
        I - stand-alone s - suspended
        H - Hot-standby (LACP only) 
        R - Layer3      S - Layer2 
        U - in use      f - failed to allocate aggregator 
        u - unsuitable for bundling 
        w - waiting to be aggregated 
        d - default port 

Number of channel-groups in use: 2 
Number of aggregators: 2 Group  

Port-channel  Protocol    Ports 
------+-------------+-----------+------------------------------------- 

2      Po2(SU)           PAgP   Fa0/1(P) Fa0/2(P) 
3      Po3(SU)           -      Fa0/3(D) Fa0/4(P)

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button