120 Labs for Cisco CCNA 200-125 and CCENT Exams

Lab 75: Configuring OSPF on Point-to-Point Networks

Lab Objective:

The objective of this lab exercise is for you to learn and understand how to enable Open Shortest Path First (OSPF) on point-to-point network types. These include High-level Data Link Control (HDLC) and point-to-point protocol (PPP).

Lab Purpose:

Enabling OSPF on point-to-point network types is a fundamental skill. OSPF is the most popular Interior Gateway Protocol (IGP) and it is imperative to understand how OSPF adjacencies are established on point-to-point network types. OSPF uses the concept of Areas. In order for two OSPF-enabled routers to establish an adjacency, they must reside in the same OSPF Area. Unlike EIGRP, which uses autonomous system numbers (ASNs), OSPF is enabled using a locally significant process ID. As a Cisco engineer, as well as in the Cisco CCNA exam, you will be expected to know how to enable OSPF on point-to-point network types.

Certification Level:

This lab is suitable for ICND2 and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 5/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 10 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure the hostnames on R1 and R3 as illustrated in the topology.

Task 2:

Configure R1 S0/0, which is a DCE, to provide a clock rate of 768 Kbps to R3. Enable PPP on the link between R1 and R3 and configure the IP addresses illustrated in the topology (we will cover this in detail later so just copy my commands for now).

Task 3:

Enable OSPF in area 0 between R1 and R3. For R1, use OSPF process ID 1. For R3 use OSPF process ID 3. Verify that your OSPF adjacency has formed between R1

and R3. Also verify that the default network type for the PPP link between R1 and R3 is point-to-point.

Configuration and Verification

Task 1:

For reference information on configuring hostnames, please refer to earlier labs.

Task 2:

R1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#int s0/0 
R1(config-if)#clock rate 768000 
R1(config-if)#encapsulation ppp 
R1(config-if)#ip address 172.16.1.1 255.255.255.192 
R1(config-if)#no shut 
R1(config-if)#end 
R1# 

R3#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R3(config)#int s0/0 
R3(config-if)#ip address 172.16.1.2 255.255.255.192 
R3(config-if)#encap ppp 
R3(config-if)#no shutdown 
R3(config-if)#^Z 
R3# 

R1#ping 172.16.1.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Task 3:

NOTE: Unlike EIGRP configuration where wildcard masks following network statements are optional, in OSPF you MUST use a wildcard mask with your network statements. To determine the wildcard mask, you can simply subtract the network mask for the network on which you want to enable OSPF from the broadcast mask. This concept is illustrated in the subtraction table shown below:

In our example, the subnet mask of the 172.16.1.0/26 subnet is 255.255.255.192. If this is subtracted from the broadcast mask of 255.255.255.255, the result is 0.0.0.63, which is the wildcard mask we used to enable OSPF for this subnet. Take some time to practice configuring wildcard masks for different subnets.

R1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#router ospf 1 
R1(config-router)#network 172.16.1.0 0.0.0.63 area 0 
R1(config-router)#end 
R1# 

R3#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R3(config)#router ospf 3 
R3(config-router)#network 172.16.1.0 0.0.0.63 area 0 
R3(config-router)#^Z 
R3# 

R1#show ip ospf neighbor
Neighbor ID    Pri   State       Dead Time   Address         Interface 
172.16.1.2       0   FULL/  -    00:00:36    172.16.1.2      Serial0/0 

R1#show ip ospf interface serial0/0 
Serial0/0 is up, line protocol is up 
 Internet Address 172.16.1.1/26, Area 0   
Process ID 1, Router ID 172.16.1.1, Network Type POINT_TO_POINT, Cost: 64 
 Transmit Delay is 1 sec, State POINT_TO_POINT, 
 Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 oob-resync timeout 40 
 Hello due in 00:00:06 
Index 1/1, flood queue length 0 
Next 0x0(0)/0x0(0) 
Last flood scan length is 1, maximum is 1 
Last flood scan time is 0 msec, maximum is 0 msec 
Neighbor Count is 1, Adjacent neighbor count is 1     
Adjacent with neighbor 172.16.1.2 
Suppress hello for 0 neighbor(s)

NOTE: When verifying OSPF adjacencies, always ensure that neighbors are in the FULL state for point-to-point networks. If they are in any other state, you will need to perform some troubleshooting to identify the root cause of the issue. Take a moment to look at the detail contained in the output of the show ip ospf interface serial0/0 command. From this output, we can determine that the OSPF network type is point-to-point (Network Type POINT_TO_POINT), the interface has an OSPF metric, or cost, of 64 (Cost: 64), and at the very bottom, there is one OSPF neighbor with which an OSPF adjacency has been created via this interface (Adjacent with neighbor 172.16.1.2).

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button