120 Labs for Cisco CCNA 200-125 and CCENT Exams

Lab 84: Configuring EIGRP Routing Using Wildcard Masks

Lab Objective:

The objective of this lab exercise is for you to learn and understand how to enable EIGRP routing using a single autonomous system while using a wildcard mask for EIGRP network statements.

Lab Purpose:

Enabling basic EIGRP routing using wildcard masks is a fundamental skill. As a Cisco engineer, as well as in the Cisco CCNA exam, you will be expected to know how to enable basic EIGRP routing while using wildcard masks.

Certification Level:

This lab is suitable for CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 7/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 20 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure hostnames on R1, R2, and Sw1 as illustrated in the topology.

Task 2:

Configure VLAN10 named EIGRP_10 and VLAN20 named EIGRP_20 on Sw1. Next, configure Sw1 F0/2 and F0/3 as trunks. These should be connected to R1 and R2 F0/0 interfaces, respectively.

Task 3:

Configure subinterfaces Fa0/0.10 and F0/0.20 on R1 and R2, respectively. Subinterface Fa0/0.10 on either router should be associated with VLAN10 and subinterface Fa0/0.20 on either router should be associated with VLAN20. Configure IP addresses on both the subinterfaces as illustrated in the topology.

Task$ 4:

Ping between R1 and R2 on subinterface Fa0/0.10 and Fa0/0.20 to verify IP connectivity.

Task 5:

Enable EIGRP using ASN 10 between R1 and R2 F0/0.10 subinterfaces. EIGRP using ASN 10 should only be enabled for these interfaces. Use a wildcard mask to achieve this.

Task 6:

Enable EIGRP using ASN 20 between R1 and R2 F0/0.20 subinterfaces. EIGRP using ASN 20 should only be enabled for these interfaces. Use a wildcard mask to achieve this.

Task 7:

Verify that you have two EIGRP adjacencies on R1 and R2. One adjacency should be for EIGRP using ASN 10 and the other for EIGRP using ASN 20.

Configuration and Verification

Task 1:

For reference information on configuring hostnames, please refer to earlier labs.

Task 2:

Sw1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
Sw1(config)#vlan10 
Sw1(config-vlan)#name EIGRP_10 
Sw1(config-vlan)#exit 
Sw1(config)#vlan20 
Sw1(config-vlan)#name EIGRP_20 
Sw1(config-vlan)#exit 
Sw1(config)#int f0/2 
Sw1(config-if)#switchport mode trunk 
Sw1(config-if)#no shut 
Sw1(config-if)#exit 
Sw1(config)#int f0/3 
Sw1(config-if)#switchport mode trunk 
Sw1(config-if)#no shut 
Sw1(config-if)#^Z 

Sw1#show interfaces trunk 

Port        Mode         Encapsulation  Status        Native vlan 
Fa0/2       on           802.1q         trunking      1 
Fa0/3       on           802.1q         trunking      1 

Port        Vlans allowed on trunk 
Fa0/2       1-4094 
Fa0/3       1-4094

Port        Vlans allowed and active in management domain 
Fa0/2       1,10,20 
Fa0/3       1,10,20

Port        Vlans in spanning tree forwarding state and not pruned 
Fa0/2       1,10,20 
Fa0/3       1,10,20 

Sw1#show vlan id 10 

VLAN Name                             Status    Ports 
---- -------------------------------- --------- ---------------------- 
10   EIGRP_10                         active    Fa0/2, Fa0/3 

Sw1#show vlan id 20 

VLAN Name                             Status    Ports 
---- -------------------------------- --------- ---------------------- 
20   EIGRP_20                         active    Fa0/2, Fa0/3

Task 3:

R1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#int fa0/0 
R1(config-if)#no shutdown 
R1(config-if)#int fa0/0.10 
R1(config-subif)#encapsulation dot1q 10 
R1(config-subif)#ip address 192.168.10.1 255.255.255.252 
R1(config-subif)#exit 
R1(config)#int fa0/0.20 
R1(config-subif)#encapsulation dot1q 20 
R1(config-subif)#ip address 192.168.20.1 255.255.255.252 
R1(config-subif)#end 
R1#show ip int bri 
Interface       IP-Address    OK? Method Status                Protocol
Fast0/0         unassigned    YES manual up                    up   
Fast0/0.10      192.168.10.1  YES manual up                    up   
Fast0/0.20      192.168.20.1  YES manual up                    up   

R2#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R2(config)#int fa0/0 
R2(config-if)#no shutdown 
R2(config-if)#int fa0/0.10 
R2(config-subif)#encapsulation dot1q 10 
R2(config-subif)#ip address 192.168.10.2 255.255.255.252 
R2(config-subif)#exit 
R2(config)#int fa0/0.20 
R2(config-subif)#encapsulation dot1q 20 
R2(config-subif)#ip address 192.168.20.2 255.255.255.252 
R2(config-subif)#end 
R2# 
R2#show ip interface brief 
Int            IP-Address      OK? Method Status              Protocol 
Fast0/0        unassigned      YES manual up                  up   
Fast0/0.10     192.168.10.2    YES manual up                  up   
Fast0/0.20     192.168.20.2    YES manual up                  up

Task 4:

R1#ping 192.168.10.2 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms 

R1#ping 192.168.20.2 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms

Task 5:

R1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#router eigrp 10 
R1(config-router)#network 192.168.10.0 0.0.0.3 
R1(config-router)#end 
R1# 

R2#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R2(config)#router eigrp 10 
R2(config-router)#network 192.168.10.0 0.0.0.3 
R2(config-router)#^Z 
*Mar  1 00:52:23.436: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.10.1 (FastEthernet0/0.10) is up: new adjacency 
R2#

Task 6:

R1#config t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#router eigrp 20 
R1(config-router)#net 192.168.20.0 0.0.0.3 
R1(config-router)#end 
R1# 

R2#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R2(config)#router eigrp 20 
R2(config-router)#network 192.168.20.0 0.0.0.3 
R2(config-router)#^Z
*Mar  1 01:08:55.887: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 20: Neighbor 192.168.20.1 (FastEthernet0/0.20) is up: new adjacency 
R2#

Task 7:

R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 10 
H   Address           Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                      (sec)         (ms)       Cnt Num 
0   192.168.10.2      Fa0/0.10          12 00:18:51    1  4500  0  1 
IP-EIGRP neighbors for process 20 
H   Address           Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                      (sec)         (ms)       Cnt Num 
0   192.168.20.2      Fa0/0.20          12 00:02:20    1  4500  0  1 
R2#show ip eigrp neighbors 
IP-EIGRP neighbors for process 10 
H   Address           Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                      (sec)         (ms)       Cnt Num 
0   192.168.10.1      Fa0/0.10          10 00:17:58 1907  5000  0  1 
IP-EIGRP neighbors for process 20 
H   Address           Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                      (sec)         (ms)       Cnt Num 
0   192.168.20.1      Fa0/0.20          11 00:01:26  452  2712  0  1

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button