120 Labs for Cisco CCNA 200-125 and CCENT Exams

Lab 89: EIGRP Split Horizon

Lab Objective:

The objective of this lab exercise is for you to learn and understand the effects of split horizon in a typical hub-and-spoke topology. Feel free to skip this lab because it’s unlikely to come up in the exam. Just note the command to disable split horizon below.

Lab Purpose:

Configuring and troubleshooting split horizon is a fundamental skill. EIGRP is an advanced distance vector protocol and as such uses split horizon to prevent routing loops. Split horizon mandates that EIGRP will not send updates back out of the interface on which they were received. While this default feature is generally a good thing, it can have a disastrous effect on traditional hub-and-spoke topologies. As a Cisco engineer, as well as in the Cisco CCNA exam, you will be expected to know how to address split horizon issues in EIGRP.

Certification Level:

This lab is suitable for ICND2 and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 8/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 20 minutes.

IMPORTANT NOTE:In order to configure frame relay between two routers in your lab, you will need THREE routers! The first two routers will be regular routers, and the third will need to be configured as a frame relay switch. This can be any Cisco router that has at least two Serial interfaces. Please refer to Appendix B: Cabling and Configuring a Frame Relay Switch For Three Routers for the appropriate configuration to issue on the frame relay switch.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

This lab will only be performed on R1, R2, and R3. Configure hostnames on R1, R2, and R3 as shown above.

Task 2:

Configure the switch in the topology with the hostname Sw1. Enable F0/1, F0/2, and F0/4 on Sw1 so that when you bring up the router interfaces connected to those switchports they can come up.

Task 3:

Configure IP addresses on the Fa0/0 interfaces on R1, R2, and R3. Make sure that you enable these interfaces and they are up.

Task 4:

Configure frame relay on R1, R2, and R3. Use the IP addresses in the topology for their respective Serial interfaces. Use the default frame relay encapsulation of Cisco. Configure static frame relay maps between R1, R2, and R3, so that each router has a static frame relay map to the other two routers on the frame relay network.

Task 5:

Enable EIGRP in ASN 1760 on R1, R2, and R3 for all the subnets configured on those respective routers. Be sure to prevent EIGRP from automatically summarizing at classful network boundaries.

Task 6:

If you have configured everything as requested, you will not be able to see the 10.1.1.0/24 route via EIGRP on R3, nor will you be able to see the 172.16.3.0/25 route via EIGRP on R2. However, R1 will have both routes. Verify that this is the case using the appropriate commands.

Task 7:

Based on your studies, you know that the reason you are not seeing the 10.1.1.0/24 route via EIGRP on R3 and the 172.16.3.0/25 route via EIGRP on R2 is because these routes are both sent to R1 via EIGRP, but since distance vector protocols do not send routing information back out of the same interface they received it, R1 will not send the routing information for 10.1.1.0/24 to R3 or the routing information for 172.16.3.0/25 since the routing information was received on the same interface. To prevent this from happening, disable this default feature.

Task 8:

Now verify that you can see the 10.1.1.0/24 route via EIGRP on R3 and the 172.16.3.0/25 route via EIGRP on R2. Ping 10.1.1.1 from R3 and 172.16.3.3 from R2 to verify network connectivity.

Configuration and Verification

Task 1:

For reference information on configuring hostnames, please refer to earlier labs.

Task 2:

For reference information on configuring opening (no shutting) switch interfaces, please refer to earlier labs.

Task 3:

For reference information on configuring IP addresses, please refer to earlier labs.

Task 4:

For reference information on verifying frame relay mapping, please refer to earlier labs.

R1#show frame-relay map 
Serial1/0 (up): ip 10.0.0.2 dlci 102(0x66,0x1860), static, broadcast, CISCO, status defined, active 
Serial1/0 (up): ip 10.0.0.3 dlci 103(0x67,0x1870), static, broadcast, CISCO, status defined, active 

R2#show frame-relay map 
Serial0/0 (up): ip 10.0.0.1 dlci 201(0xC9,0x3090), static, broadcast, CISCO, status defined, active 
Serial0/0 (up): ip 10.0.0.3 dlci 201(0xC9,0x3090), static, broadcast, CISCO, status defined, active 

R3#show frame-relay map 
Serial1/0 (up): ip 10.0.0.1 dlci 301(0x12D,0x48D0), static, broadcast, CISCO, status defined, active 
Serial1/0 (up): ip 10.0.0.2 dlci 301(0x12D,0x48D0), static, broadcast, CISCO, status defined, active

Task 5:

R1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#router eigrp 1760 
R1(config-router)#no auto-summary 
R1(config-router)#net 10.0.0.0 
R1(config-router)#network 192.168.1.0 
R1(config-router)#end 
R1# 

R2#config t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R2(config)#router eigrp 1760 
R2(config-router)#no auto-summary 
R2(config-router)#network 10.0.0.0 
R2(config-router)#network 10.1.1.0 
R2(config-router)#^Z 
R2# 

R3#config t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R3(config)#router eigrp 1760 
R3(config-router)#no auto-summary 
R3(config-router)#network 10.0.0.0 
R3(config-router)#network 172.16.3.0 
R3(config-router)#^Z 
R3# 

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1760 
H   Address           Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                      (sec)         (ms)       Cnt Num 
1   10.0.0.2          Se1/0            165 00:01:07   24   200  0  2 
0   10.0.0.3          Se1/0            153 00:01:25  124   744  0  2 

R2#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1760 
H   Address           Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                      (sec)         (ms)       Cnt Num 
0   10.0.0.1          Se0/0            128 00:00:53  911  5000  0  4 

R3#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1760 
H   Address           Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                      (sec)         (ms)       Cnt Num 
0   10.0.0.1          Se1/0            156 00:02:20    8   200  0  4

Task 6:

R3#show ip route eigrp 
192.168.1.0/26 is subnetted, 1 subnets 
D       192.168.1.0 [90/2195456] via 10.0.0.1, 00:10:53, Serial1/0 

R2#show ip route eigrp 
        192.168.1.0/26 is subnetted, 1 subnets 
D       192.168.1.0 [90/2195456] via 10.0.0.1, 00:10:55, Serial0/0 

R1#show ip route eigrp 
        172.16.0.0/25 is subnetted, 1 subnets 
D       172.16.3.0 [90/2195456] via 10.0.0.3, 00:12:23, Serial1/0 
        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
D       10.1.1.0/24 [90/2195456] via 10.0.0.2, 00:12:04, Serial1/0

Task 7:

R1#conf t
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#int s1/0 
R1(config-if)#no ip split-horizon eigrp 1760 
R1(config-if)#end 
R1# 
*Mar  1 01:20:39.104: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1760: Neighbor 10.0.0.2 (Serial1/0) is down: split horizon changed 
*Mar  1 01:20:39.108: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1760: Neighbor 10.0.0.3 (Serial1/0) is down: split horizon changed 
*Mar  1 01:20:39.677: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1760: Neighbor 10.0.0.3 (Serial1/0) is up: new adjacency 
*Mar  1 01:21:34.122: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1760: Neighbor 10.0.0.2 (Serial1/0) is up: new adjacency

NOTE: When you disable (or re-enable) split horizon on an interface, all EIGRP adjacencies that have been established via that interface are reset as indicated in the output above. You can verify that the neighbors have been re-established successfully using the show ip eigrp neighbors command as illustrated in the following output:

R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1760 
H   Address           Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                      (sec)         (ms)       Cnt Num 
1   10.0.0.2          Se1/0            131 00:00:50 1512  5000  0  4 
0   10.0.0.3          Se1/0            131 00:01:44   13   200  0  5

Task 8:

R2#show ip route eigrp 
        172.16.0.0/25 is subnetted, 1 subnets 
D       172.16.3.0 [90/2707456] via 10.0.0.1, 00:00:05, Serial0/0 
        192.168.1.0/26 is subnetted, 1 subnets 
D       192.168.1.0 [90/2195456] via 10.0.0.1, 00:00:05, Serial0/0 

R2#ping 172.16.3.3

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.3.3, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/32/40 ms 

R3#show ip route eigrp 
        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
D       10.1.1.0/24 [90/2707456] via 10.0.0.1, 00:00:47, Serial1/0 
        192.168.1.0/26 is subnetted, 1 subnets 
D       192.168.1.0 [90/2195456] via 10.0.0.1, 00:00:47, Serial1/0 

R3#ping 10.1.1.2 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/27/32 ms

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button