120 Labs for Cisco CCNA 200-125 and CCENT Exams

Lab 99: Configuring eBGP Advanced

Lab Objective

The objective of this lab exercise is for you to learn how to configure eBGP and some of its advanced features.

Lab Purpose:

Border Gateway Protocol (BGP) is the routing protocol used to exchange information on the Internet; in this lab, we will configure some of the advanced features of the exterior BGP relationships. As a Cisco engineer, as well as in the Cisco CCNA exam, you will be expected to know how to implement eBGP (external BGP) features in your network.

Certification Level:

This lab is suitable for ICND2 and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 9/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 20 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Task 1:

Configure hostnames on R1 and R2 as illustrated in the topology.

Task 2:

Configure each router with its respective IPv4 addresses in both the Loopback and GigabitEthernet interfaces.

Note: Configure a static route to Loopback100 and Loopback200, respectively.

Task 3:

Configure an eBGP session between R1 and R2 with the following requirements:

  • R1 will be inside ASN 100 and R2 will be inside ASN 200;
  • R1 should use Loopback100 as the peer source address and R2 should do the same;
  • Make sure that if at some point R2 learns an IP prefix from another BGP router and then sends it to R1, the next hop address will remain as the R2 IP address (increase the TTL to 2);
  • Hellos will be sent every 5 seconds, with a hold timer of 15 seconds;
  • Authentication will be done with the password CCNA (unencrypted); and
  • Make sure that they advertise their Loopback1 network address and the Gigabit interface via BGP.

Task 4:

Confirm that eBGP is working properly by running the following commands:

  • show ip protocols
  • show ip bgp summary
  • show ip route bgp
  • Ping 192.168.2.1 source Loopback1 (from R1)
  • Ping 192.168.1.1 source Loopback1 (from R2)

Configuration and Verification

Task 1:

For reference information on configuring hostnames, please refer to earlier labs.

Task 2:

R1#conf t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#int fa0/0 
R1(config-if)#ip address 192.168.10.1 255.255.255.0 
R1(config-if)#no shut 
R1(config)#int loopback1 
R1(config-if)#ip address 192.168.1.1 255.255.255.0 
R1(config)#int loopback100 
R1(config-if)#ip address 192.168.100.1 255.255.255.0 
R1(config)#ip route 192.168.200.0 255.255.255.0 192.168.10.2 

R2(config)#int fa0/0 
R2(config-if)#ip address 192.168.10.2 255.255.255.0 
R2(config-if)#no shut 
R2(config)#int loopback1 
R2(config-if)#ip address 192.168.2.1 255.255.255.0 
R2(config)#int loopback200 
R2(config-if)#ip address 192.168.200.1 255.255.255.0 
R2(config)#ip route 192.168.100.0 255.255.255.0 192.168.10.1

Task 3:

R1#config t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R1(config)#router bgp 100 
R1(config-router)#neighbor 192.168.200.1 remote-as 200 
R1(config-router)#neighbor 192.168.200.1 update-source loopback100 
R1(config-router)#neighbor 192.168.200.1 ebgp-multihop 2
R1(config-router)#neighbor 192.168.200.1 timers 5 15 
R1(config-router)#neighbor 192.168.200.1 password CCNA 
R1(config-router)#network 192.168.10.0 mask 255.255.255.0 
R1(config-router)#network 192.168.1.0 mask 255.255.255.0 

R2#config t 
Enter configuration commands, one per line.  End with CTRL/Z. 
R2(config)#router bgp 200 
R2(config-router)#neighbor 192.168.100.1 remote-as 100 
R2(config-router)#neighbor 192.168.100.1 update-source loopback200 
R2(config-router)#neighbor 192.168.100.1 ebgp-multihop 2 
R2(config-router)#neighbor 192.168.100.1 next-hop-self 
R2(config-router)#neighbor 192.168.100.1 timers 5 15 
R2(config-router)#neighbor 192.168.100.1 password CCNA 
R2(config-router)#network 192.168.10.0 mask 255.255.255.0 
R2(config-router)#network 192.168.2.0 mask 255.255.255.0

Task 4:

R1#sh ip bgp summary     
BGP router identifier 192.168.100.1, local AS number 100 
BGP table version is 4, main routing table version 4 
3 network entries using 351 bytes of memory 
4 path entries using 208 bytes of memory 
3/2 BGP path/bestpath attribute entries using 372 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
BGP using 931 total bytes of memory 
BGP activity 3/0 prefixes, 4/0 paths, scan interval 60 secs 

Neighbor     V  AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.200.1 4 200    37      37        4    0    0 00:33:15        2 

R1#show ip protocols 
Routing Protocol is “bgp 100” 
 Outgoing update filter list for all interfaces is not set
 Incoming update filter list for all interfaces is not set 
 IGP synchronization is disabled 
 Automatic route summarization is disabled 
 Neighbor(s): 
  Address          FiltIn FiltOut DistIn DistOut Weight RouteMap 
  192.168.200.1                                          
 Maximum path: 1 
 Routing Information Sources: 
  Gateway         Distance      Last Update 
  192.168.200.1         20      00:32:56 
 Distance: external 20 internal 200 local 200 

R1#sh ip route bgp 
B    192.168.2.0/24 [20/0] via 192.168.100.1, 00:32:59 

R1#ping 192.168.2.1 source loopback 1 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds: 
Packet sent with a source address of 192.168.1.1 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/14/20 ms 

R2#sh ip bgp summary 
BGP router identifier 192.168.100.1, local AS number 200 
BGP table version is 4, main routing table version 4 
3 network entries using 351 bytes of memory 
4 path entries using 208 bytes of memory 
3/2 BGP path/bestpath attribute entries using 372 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
BGP using 931 total bytes of memory 
BGP activity 3/0 prefixes, 4/0 paths, scan interval 60 secs 

Neighbor     V  AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
192.168.100.1 4 100    39      39        4    0    0 00:35:19        2

R2#show ip protocols 
Routing Protocol is “bgp 200” 
 Outgoing update filter list for all interfaces is not set 
 Incoming update filter list for all interfaces is not set 
 IGP synchronization is disabled 
 Automatic route summarization is disabled 
 Neighbor(s): 
  Address          FiltIn FiltOut DistIn DistOut Weight RouteMap 
  192.168.100.1                                          
 Maximum path: 1 
 Routing Information Sources: 
  Gateway         Distance      Last Update 
  192.168.100.1         20      00:34:52 
 Distance: external 20 internal 200 local 200 

R2#show ip route bgp 
B    192.168.1.0/24 [20/0] via 192.168.100.1, 00:34:56 

R2#ping 192.168.1.1 source loopback1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: 
Packet sent with a source address of 192.168.2.1 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/24 ms

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button