ICND2 Labs

Lab 3-1: Implementing EIGRP

Physical Topology Diagram

  • Visual Topology
  • Command List
  • Task 1: Remote network connectivity.
  • Task 2: Configure EIGRP
  • Task 3: Using show commands to verify EIGRP parameters

Visual Topology

Command List

Command Description
debug eigrp neighbors Debugs eigrp events
network network [wildcard mask] Enables the routing protocol on the interfaces, an optional wildcard mask can be used to narrow down the interface list
no auto-summary Disable auto-summarization at the classful boundary point.
no router eigrp autonomous-system Disables the routing process
router eigrp autonomous-system Enters the router configuring mode
show ip eigrp neighbors Displays the contents of the neighbourship table
show ip eigrp topology Displays the contents of the topology table, successors and feasible successors only.
show ip protocols Displays details of active routing protocols
show ip route Displays the contents of the IPv4 routing table (best paths)
undebug all Turns off all debugging events

Task 1: Remote Network Connectivity.

Step 1: Access the CLI on your switch and shutdown all unused ports.

For this exercise, only fa0/1 and fa0/12 are used.

Step 2: Make sure both fa0/1 and fa0/12 are setup as access ports and assigned to VLAN1.

Hint.....Switchport mode access
         Switchport access vlan 1

Step 3: Enable portfast of fa0/1 and fa0/12

Hint....spanning-tree portfast

Step 4: Enable fa0/1 and fa0/12

Step 5: Examine the IP address of your PC and if necessary change it to the following values.

PC1 10.1.1.100 / 24 default gateway 10.1.1.1
PC2 10.2.2.100 /24 default gateway 10.2.2.1

If your PC has two networking cards then type in the following commands at the system prompt to redirect traffic out of the correct interface.

PC1 c:\>route -p add 10.2.2.0 mask 255.255.255.0 10.1.1.1
PC2 c:\>route -p add 10.1.1.0 mask 255.255.255.0 10.2.2.1

Step 6: Access the CLI on your router.

Clear down any previous configuration, assign a host name of R1 or R2 and configure the following IP addresses.

R1 only....
fa0/0 or gi0/0 10.1.1.1 /24
fa0/1 or gi0/1 172.16.1.17 /28
R2 only....
fa0/0 or gi0/0 10.2.2.1 /24
fa0/1 or gi0/1 172.16.1.18 /28

Step 7: Enable both interfaces and check their status is up/up

Step 8: From your PC ping your default gateway, this should be successful!
Troubleshoot if the ping fails.

Step 9: From your PC ping the IP address of the other PC.
This should fail, why?

Task 2: Configure EIGRP.

Step 1: Access the CLI on the Router

Step 2: Enter the configuration mode for EIGRP using an autonomous system number of 100.

Do the autonomous system numbers need to match for the two routers to become neighbours?

Step 3: While in router configuration mode enter a network command which identifies the specific IP addresses configured on both ethernet interfaces.

Hint….Wildcard mask required

What networks will be advertised from R1 to R2 and R2 to R1?

Use the show ip route command to validate your answers and fill in the table below.

Source Destination Mask Type: summary or connected Exit interface

Step 4: Execute a command which prevents the auto-summarization at a classful boundary point.

Step 5: Use the Show ip route command and compare the results against the table in step 3.

Source Destination Mask Type: summary or connected Exit interface

Which routing protocols auto-summarize by default?

Task 3: Using Show Commands to Verify EIGRP Parameters

Step 1: Run the sh ip eigrp nei command and inspect the output.

How many neighbours do you have?

What is the purpose of the hold time value?

How often are hello packets sent?

Step 2: Run the sh ip eigrp top command and inspect the output.

How many entries do you have?

Do you have any feasible successors? If not why not?

What does the FD value represent? and how is it calculated?

Step 3: Run the sh ip protocols command and inspect the output.

How many routing protocols are running?

What does Distance: internal 90 external 170 signify?

When would you change the variance value from its default of 1?

Step 4: Save your running-config.

Lab Answer Keys:

[sociallocker id=”4139″]

Task 1: Remote Network Connectivity.

Step 1: Access the CLI on your switch and shutdown all unused ports.

SW(config)#int range fa0/1 - 24
SW(config-if-range)#shut

Step 2: Make sure both fa0/1 and fa0/12 are setup as access ports and assigned to VLAN1.

SW(config)#int range fa0/1, fa0/12
SW(config-if-range)#switchport mode access
SW(config-if-range)#switchport access vlan 1

Step 3: Enable portfast of fa0/1 and fa0/12

SW(config-if-range)#spanning-tree portfast

Step 4: Enable fa0/1 and fa0/12

SW(config-if-range)#no shut

Step 6: Access the CLI on your router.

Clear down any previous configuration, assign a host name of R1 or R2 and configure the following IP addresses.

Router#erase startup-config
Router#reload
confirm reload
R1 only....
Router>en
Router#conf t
Router(config)#host R1
R1(config)#int fa0/0

or

R1(config)#int gi0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int fa0/1

or

R1(config-if)#int gi0/1
R1(config-if)#ip address 172.16.1.17 255.255.255.240
R1(config-if)#no shut
R2 only....
Router>en
Router#conf t
Router(config)#host R2
R2(config)#int fa0/0

or

R2(config)#int gi0/0
R2(config-if)#ip address 10.2.2.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#int fa0/1

or

R2(config-if)#int gi0/1
R2(config-if)#ip address 172.16.1.18 255.255.255.240
R2(config-if)#no shut

Step 9: From your PC ping the IP address of the other PC.

This should fail, why?

Because you don’t have a path to the remote subnet in your routing table.

Task 2: Configure EIGRP.

Step 1: Access the CLI on the Router

Step 2: Enter the configuration mode for EIGRP using an autonomous system number of 100.

R(config)#router eigrp 100
R(config-router)#

Do the autonomous system numbers need to match for the two routers to become neighbours?

YES

EIGRP neighbours need to agree on a number of parameters before they exchange routing information.

AS number

K values (metrics being used)

Peer devices on the same logical IP subnet

Authentication policy (not used or MD5)

Step 3: While in router configuration mode enter a network command which identifies the specific IP addresses configured on both ethernet interfaces.

R1 only....
R1(config-router)#network 10.1.1.1 0.0.0.0
R1(config-router)#network 172.16.1.17 0.0.0.0
R2 only....
R2(config-router)#network 10.2.2.1 0.0.0.0
R2(config-router)#network 172.16.1.18 0.0.0.0

What networks will be advertised from R1 to R2 and R2 to R1?

Summarized 10.0.0.0 /8

Step 4: Execute a command which prevents the auto-summarization at a classful boundary point.

R(config-router)#no auto-summary

Which routing protocols auto-summarize by default?

Distance vector based protocols
RIP v1
RIP v2
IGRP
EIGRP

Task 3: Using Show Commands to Verify EIGRP Parameters

Step 1: Run the sh ip eigrp nei command and inspect the output.

How many neighbours do you have?

You should see 1 neighbour

What is the purpose of the hold time value?

15 seconds by default on LAN connections, if I don’t receive an hello packet from an established neighbour for 15 seconds, I assume the neighbour has gone off line and I recalculate my topology table.

How often are hello packets sent?

5 seconds by default on LAN connections, used to discovery neighbours and also a keepalive mechanism.

Step 2: Run the sh ip eigrp top command and inspect the output.

How many entries do you have?

Should see 3, two local networks and one remote.

Do you have any feasible successors? If not why not?

NO because you only have 1 viable path to your remote network.

What does the FD value represent? and how is it calculated?

Feasible Distance is the metric value to any destination, it is calculated by adding the advertised distance (reported distance) to the calculated link distance between you and your neighbour. The K values control which metric components are used.

Step 3: Run the sh ip protocols command and inspect the output.

How many routing protocols are running?

1   (no dynamic routing protocols are enabled by default)

What does Distance: internal 90 external 170 signify?

Administrative distances used for internal and external (redistributed) routes.

When would you change the variance value from its default of 1?

You want to support unequal cost paths to a remote destination.

Step 4: Save your running-config.

R#copy run start
[/sociallocker]

Related Articles

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Comments
Inline Feedbacks
View all comments
Back to top button